xcode4.2 IOS5 编译低于sdk4.3的程序的办法

虽说有ios5了,可是以前的系统不能抛弃啊?于是乎当你选择的sdk低于4.3时,就出现了下页的报错:
warning: iPhone apps with a deployment target lower than 4.3 should include an armv6 architecture (current IPHONEOS_DEPLOYMENT_TARGET = “4.0”, ARCHS = “armv7”).
网上找了半天,发现一个日文博客,http://sarudeki.jp/mipoiapp/?p=692,虽然看不懂,但是截图还是好理解的,算是转载一下吧.
target那里找到build setting


找到Architectures,然后通过上下框选择other

按+号,手动添加一个armv6

保存一下,就是显示 armv6 armv7了。不过我的机器不是这么显示的,反正是好了

搞定!
xcode4万岁!


相关博文

    分享到:

About rainbird

IOS攻城狮
This entry was posted in IOS开发, xCode and tagged , , , , . Bookmark the permalink.

发表评论